Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.5.5
    • Fix Version/s: 3.0.0
    • Component/s: ui
    • Labels:
      None
    • Environment:

      Debian Weezhy

    • Similar Issues:
      Show 10 results 
    • Rank:
      6153

      Description

      When you want to display the user photo or download it, you have an error cause the photo is corrupted.
      The ob_start php function seem's to be the responsible.
      The patch is in the attachment

      1. patch_document_display.inc
        0.3 kB
        Cedric LIARD
      1. titi.jpeg
        2 kB

        Activity

        David Dolcimascolo added a comment -

        A typical user avatar

        David Dolcimascolo added a comment -

        To QA:

        • Impacts obm-ui
          • We're not using PHP output buffering anymore to download user image.
        • The difficulty with this Jira is that it used to work fine on typical VMs, but we found the issue on a client prodcution instance (on Wheezy)...
        • To test, just verify that nothing breaks around user images.

        Tested with FF 28 and Chrome 34 on Wheezy.

        Jenkins Continuous Integration Server added a comment -

        SUCCESS: Integrated in poll-next-30 472-6f4c41712e7aaff80b28b1ac4e79d5402b2f8a43
        OBMFULL-5939 Not using output buffering to download user image. (jkornobis: c9c735eccdc60255f3db2f8410539b0421f56edf)

        • ui/php/document/document_display.inc
        Jenkins Continuous Integration Server added a comment -

        SUCCESS: Integrated in poll-next-30 475-df0333c1085867b7a7998eb440aca324f2144ee0
        OBMFULL-5939 Not using output buffering to download user image. (jkornobis: 1e80f690fc5a8be3f139af86fa1784f2e952dff4)

        • ui/php/document/document_display.inc
        Stephane COLSON added a comment -

        OK with version 3.0.0-0.alpha0+git20140512_1128_0ea9a54 (CentOS and Debian)
        I didn't try to reproduce as it seems to be impossible. But I tried to add image (png and jpeg) to 2 users, then open documents and visualize theses images, with Chromium and FF.


          People

          • Assignee:
            David Dolcimascolo
            Reporter:
            Cedric LIARD
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: