OBM
  1. OBM
  2. OBMFULL-5966

obm-satellite error when restart and automaton fails

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.0.0
    • Fix Version/s: 3.0.0
    • Component/s: automate
    • Labels:
      None
    • Environment:

      OBM 3.0.0~0.alpha0+git20140516-1140-3428720

    • Similar Issues:
      Show 9 results 
    • Rank:
      6191

      Description

      After a fresh install of obm-full on Wheezy with version 3.0.0~0.alpha0+git20140516-1140-3428720, automaton (yellow chip) fails because apparently obm-satellite is not correctly started.

      When restarting obm-satellite, here are the logs:

      obm-satelitte logs when restart
      2014/05/16 16:46:16:918364 [26514]: ObmSatellite::Server:190 INFO - Daemon stopped by TERM
      2014/05/16 16:46:16:918362 [26453]: ObmSatellite::Server:108 WARN - Daemon stopped by TERM
      2014/05/16 16:46:16:918423 [26513]: ObmSatellite::Server:190 INFO - Daemon stopped by TERM
      2014/05/16 16:46:19:6 [32734]: ObmSatellite::Server:67 INFO - Parent daemon running (PID: 32734)
      2014/05/16 16:46:20:402 [32734]: ObmSatellite::Server::configure:202 INFO - needed LDAP service initialized
      2014/05/16 16:46:21:1939 [32734]: ObmSatellite::Services::LDAP:242 ERROR - no TLS/SSL LDAP server support
      2014/05/16 16:46:21:1939 [32734]: ObmSatellite::Services::LDAP:282 INFO - Authenticating to LDAP server 'ldap://127.0.0.1/' as user DN uid=obmsatellite,ou=sysusers,dc=local
      2014/05/16 16:46:21:2186 [32734]: ObmSatellite::Services::LDAP:303 ERROR - fail to authenticate against LDAP server : Invalid credentials
      2014/05/16 16:46:21:2187 [32734]: ObmSatellite::Services::CYRUS:112 FATAL - Can't get 'cyrus' admin password from LDAP
      2014/05/16 16:46:21:2188 [32734]: ObmSatellite::Services::CYRUS:54 FATAL - Can't get Cyrus admin 'cyrus' password from LDAP
      2014/05/16 16:46:21:2188 [32734]: ObmSatellite::Server::configure:199 ERROR - unable to initialize needed CYRUS service
      2014/05/16 16:46:21:2188 [32734]: ObmSatellite::Server::module:63 ERROR - starting needed service failed. Loading module 'backupEntity' failed
      2014/05/16 16:46:21:2214 [32734]: ObmSatellite::Server::module:73 INFO - loading module 'cyrusPartition' success
      2014/05/16 16:46:21:2247 [32734]: ObmSatellite::Server::module:73 INFO - loading module 'postfixAccess' success
      2014/05/16 16:46:21:2270 [32734]: ObmSatellite::Server::module:73 INFO - loading module 'postfixSmtpInMaps' success
      2014/05/16 16:46:21:2270 [32734]: ObmSatellite::Server:220 INFO - Trying to bind to SSL port 30000 using certificate /etc/obm/certs/obm_cert.pem (key /etc/obm/certs/obm_cert.pem)
      2014/05/16 16:46:21:2271 [32734]: ObmSatellite::Server:222 INFO - CA certificate /var/lib/obm-ca/cacert.pem
      2014/05/16 16:46:22:2527 [32734]: ObmSatellite::Server:169 INFO - new child forked (PID: 32755), we now have 1 child
      2014/05/16 16:46:22:2529 [32734]: ObmSatellite::Server:169 INFO - new child forked (PID: 32756), we now have 2 child
      2014/05/16 16:46:22:2530 [32755]: ObmSatellite::Server:175 INFO - child 32755 ready to process requests
      2014/05/16 16:46:22:2534 [32756]: ObmSatellite::Server:175 INFO - child 32756 ready to process requests
      

      And if I create a host and a domain, the update with the yellow chip never ends. I infinitely have remaining updates. I'm stuck with it.

        Activity

        Your Enhancer Plugin for JIRA license is invalid

          People

          • Assignee:
            Emmanuel Surleau
            Reporter:
            Stephane COLSON
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: