OBM
  1. OBM
  2. OBMFULL-5969

CLONE - Healthcheck - Add check on charset

    Details

    • Type: New Feature New Feature
    • Status: Closed Closed
    • Priority: Normal Normal
    • Resolution: Fixed
    • Affects Version/s: 2.5.8
    • Fix Version/s: 3.0.0
    • Component/s: opush
    • Labels:
      None
    • Similar Issues:
      Show 8 results 
    • Rank:
      6194

      Description

      Healthcheck - Add check on charset

      Must have file.encoding java propery equals to UTF-8

        Issue Links

          Activity

          Hide
          Stephane COLSON added a comment - - edited

          At the moment opush 3.0.0-1 is available. The check has been added in OBM version 3.0.0~0.rc1 and fails (see checkEncoding.png) on CentOS and Debian Wheezy.
          The message is

          OPush server version at '127.0.0.1' for domain 'obm15.lyn.lng' doesn't support this check
          

          I understand that Opush version 3.0.1 will support this check but this is not clear for admin user which installed OBM and Opush with the same version 3.0.0.

          I think we should add this check in OBM version 3.0.1. Am I wrong ?

          See https://ci-obm.linagora.com/jenkins/job/poll-next-30/487/

          Show
          Stephane COLSON added a comment - - edited At the moment opush 3.0.0-1 is available. The check has been added in OBM version 3.0.0~0.rc1 and fails (see checkEncoding.png) on CentOS and Debian Wheezy. The message is OPush server version at '127.0.0.1' for domain 'obm15.lyn.lng' doesn't support this check I understand that Opush version 3.0.1 will support this check but this is not clear for admin user which installed OBM and Opush with the same version 3.0.0. I think we should add this check in OBM version 3.0.1. Am I wrong ? See https://ci-obm.linagora.com/jenkins/job/poll-next-30/487/
          Hide
          Stephane COLSON added a comment -

          For version 3.0, thanks to modify the message with:

          • "This check is supported since OPush 3.0.1+. Your server version at '<IP>' for domain '<domain>' doesn't support this check"
          Show
          Stephane COLSON added a comment - For version 3.0, thanks to modify the message with: "This check is supported since OPush 3.0.1+. Your server version at '<IP>' for domain '<domain>' doesn't support this check"
          Hide
          Jenkins Continuous Integration Server added a comment -

          SUCCESS: Integrated in poll-next-30 492-b23026d7fef775bc0bb6e5a8fc6ab12b1ee16aec
          OBMFULL-5969 Change warning message (jkornobis: b23026d7fef775bc0bb6e5a8fc6ab12b1ee16aec)

          • ui/php/healthcheck/backend/checks/opush/EncodingStatus.php
          Show
          Jenkins Continuous Integration Server added a comment - SUCCESS: Integrated in poll-next-30 492-b23026d7fef775bc0bb6e5a8fc6ab12b1ee16aec OBMFULL-5969 Change warning message (jkornobis: b23026d7fef775bc0bb6e5a8fc6ab12b1ee16aec ) ui/php/healthcheck/backend/checks/opush/EncodingStatus.php
          Hide
          Stephane COLSON added a comment -

          OK with version 3.0.1~0.alpha0+git20140602-1700-156e375 on Wheezy and CentOS
          "This check is only supported since Opush 3.0.1. The server located at '127.0.0.1' for the domain '<obmDomain>' doesn't support it"

          Show
          Stephane COLSON added a comment - OK with version 3.0.1~0.alpha0+git20140602-1700-156e375 on Wheezy and CentOS "This check is only supported since Opush 3.0.1. The server located at '127.0.0.1' for the domain '<obmDomain>' doesn't support it"
          Hide
          Stephane COLSON added a comment -

          OK with version 3.0.0-0.rc1+git20140606_1941_aec3cf7. Tested on CentOS

          Show
          Stephane COLSON added a comment - OK with version 3.0.0-0.rc1+git20140606_1941_aec3cf7. Tested on CentOS
          Hide
          Jenkins Continuous Integration Server added a comment -

          SUCCESS: Integrated in poll-qa-25 330-ed6f717eb69f0d99a65cfe5921e363f040b6ca9e
          OBMFULL-5969 Change warning message (jkornobis: ed6f717eb69f0d99a65cfe5921e363f040b6ca9e)

          • ui/php/healthcheck/backend/checks/opush/EncodingStatus.php
          Show
          Jenkins Continuous Integration Server added a comment - SUCCESS: Integrated in poll-qa-25 330-ed6f717eb69f0d99a65cfe5921e363f040b6ca9e OBMFULL-5969 Change warning message (jkornobis: ed6f717eb69f0d99a65cfe5921e363f040b6ca9e ) ui/php/healthcheck/backend/checks/opush/EncodingStatus.php

            People

            • Assignee:
              David Dolcimascolo
              Reporter:
              Antoine DUPRAT
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: