OBM
  1. OBM
  2. OBMFULL-6067

Usage of CRaSH can leak file descriptors

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Normal Normal
    • Resolution: Fixed
    • Affects Version/s: 2.5.7
    • Fix Version/s: 2.5.8
    • Component/s: opush
    • Labels:
      None
    • Story Points:
      0
    • Similar Issues:
      Show 10 results 
    • Rank:
      6339
    • Sprint:
      Lyon Sprint 26/08/2014

      Description

      Current behavior:
      Usage of CRaSH can leak file descriptors

      Expected behavior:
      No more file-descriptor leak by using the CRaSH console

        Issue Links

          Activity

          Thomas HILAIRE added a comment -

          QA: I don't think that the fix can be tested as it does not lead to any issue in a "dev" context.
          The reason is that the connection leak occurs only when you connect to crash so the OS succeed to clean its resources as it happens too few frequently... in another context we can't be sure that the resources are well managed by the OS!
          Impacts: Connection to Opush through CRaSH

          Jenkins Continuous Integration Server added a comment -

          SUCCESS: Integrated in poll-qa-25 326-1ab8d93df26b4003cca23a74864a32563e089728
          OBMFULL-6067 Always close the httpclient when the authentication is done (jkornobis: 1ab8d93df26b4003cca23a74864a32563e089728)

          • java/sync/opush/push-servlet/src/test/java/org/obm/auth/crsh/ObmSyncAuthenticationPluginTest.java
          • java/sync/opush/push-servlet/src/main/java/org/obm/auth/crsh/ObmSyncAuthenticationPlugin.java
          Matthieu EXT_BAECHLER added a comment -

          CRaSH still works after this changeset (tested on 2.5.8-0.alpha0+git20140827_1600_1ab8d93)

          We'll say it's enough.


            People

            • Assignee:
              Thomas HILAIRE
              Reporter:
              Thomas HILAIRE
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Agile