Opush
  1. Opush
  2. OP-188

On some intallations synchronization can modify the day of allday events

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Normal Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.1.0
    • Labels:
      None
    • Rank:
      6803

      Description

      Pre-conditions

      1. Have a UTC machine, or start opush with -Duser.timezone=UTC
      2. Have usera with an ios device on Europe/Paris
      3. Have usera with obm-ui on Europe/Paris

      Reproduction steps

      1. As usera with ios, create an allday event, synchronize
      2. As usera with ui, modify the name of this event
      3. As usera with ios, synchronize

      Current behavior

      1. NOK the event is shown one day before on the device

      Expected behavior

      1. OK the event name is changed and it appears at the same day on the device

      Additional informations

        Issue Links

          Activity

          Jenkins Continuous Integration Server added a comment -

          UNSTABLE: Integrated in opush-master #218
          OP-189 OP-188 The obm-sync value is already right (thilaire: 49f611ab0f607d284d987c6e461c1078316a17bf)

          • obm-backend/src/test/java/org/obm/push/calendar/ConvertObmEventToMsEventIntegrityTest.java
          • obm-backend/src/test/java/org/obm/push/calendar/ConvertObmEventByICSLoopTest.java
          • obm-backend/src/main/java/org/obm/push/calendar/ObmEventToMSEventConverterImpl.java
          Antoine DUPRAT added a comment -

          NOK
          Tested on Debian wheezy with Opush 3.1.0~alpha0~git20150327.162644.3b1273a & OBM 3.1.4~1

          Android iOS
          Nexus 4, 5.0.1 OK iPhone, 5.1.1 OK
          Galaxy S2, 4.1.2 OK iPhone, 7.1.2 NOK

          When creating a allday event on iPhone 7.1.2, it appears on two days in obm-ui.

          Creation request sent:

          <?xml version="1.0" encoding="UTF-8"?><Sync>
          <Collections>
          <Collection>
          <SyncKey>a293696f-c610-4901-be2d-2f0681cd675c</SyncKey>
          <CollectionId>6</CollectionId>
          <GetChanges/>
          <WindowSize>25</WindowSize>
          <Options>
          <FilterType>5</FilterType>
          <BodyPreference>
          <Type>1</Type>
          <TruncationSize>32768</TruncationSize>
          </BodyPreference>
          </Options>
          <Commands>
          <Add>
          <ClientId>177</ClientId>
          <ApplicationData>
          <TimeZone>4AEAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAsAAAABAAEAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
          AAAAAMAAAACAAMAAAAAAAAAxP///w==</TimeZone>
          <AllDayEvent>1</AllDayEvent>
          <BusyStatus>2</BusyStatus>
          <DTStamp>20150331T084443Z</DTStamp>
          <EndTime>20150408T070000Z</EndTime>
          <Sensitivity>0</Sensitivity>
          <Subject>Test6</Subject>
          <StartTime>20150407T070000Z</StartTime>
          <UID>78A5582267494AB3A9FDA242C549828F0</UID>
          <MeetingStatus>0</MeetingStatus>
          </ApplicationData>
          </Add>
          </Commands>
          </Collection>
          </Collections>
          </Sync>
          

          Creation in obm-sync:

          <?xml version="1.0" encoding="UTF-8"?>
          <event xmlns="http://www.obm.org/xsd/sync/event.xsd" allDay="true" anonymized="false" isInternal="true" sequence="0" type="VEVENT">
              <hash>-1756206300</hash><timeupdate>1427791483000</timeupdate><timecreate>1427791483000</timecreate><extId>a30e9449-bdfa-4462-957a-ae63c11ca6bc</extId><opacity>OPAQUE</opacity><title>Test6</title><ownerEmail>userb@adupratvm.lyon.lan</ownerEmail><date>1428390000000</date><duration>86400</duration><priority>0</priority><privacy>0</privacy>
              <attendees>
                  <attendee displayName="userb" email="userb@adupratvm.lyon.lan" isOrganizer="true" percent="0" required="REQ" state="ACCEPTED"/>
              </attendees>
              <recurrence kind="none"/>
          </event>
          

          obm-sync getSync response:

          <?xml version="1.0" encoding="UTF-8"?><calendar-changes xmlns="http://www.obm.org/xsd/sync/calendar-changes.xsd" lastSync="1427791486167">
          <removed/>
          <updated>
          <event allDay="true" anonymized="false" id="38" isInternal="true" sequence="0" type="VEVENT">
          <hash>1328355477</hash>
          <timecreate>1427791486003</timecreate>
          <extId>a30e9449-bdfa-4462-957a-ae63c11ca6bc</extId>
          <opacity>OPAQUE</opacity>
          <title>Test6</title>
          <owner>userb</owner>
          <ownerEmail>userb@adupratvm.lyon.lan</ownerEmail>
          <tz>Europe/Paris</tz>
          <date>1428390000000</date>
          <duration>86400</duration>
          <priority>0</priority>
          <privacy>0</privacy>
          <attendees>
          <attendee displayName="userb" email="userb@adupratvm.lyon.lan" isOrganizer="true" percent="0" required="REQ" state="ACCEPTED"/>
          </attendees>
          <recurrence kind="none"/>
          </event>
          </updated>
          <participationChanges/>
          </calendar-changes>
          
          Antoine DUPRAT added a comment -

          iPhone, 7.1.2 OK on Opush 3.0.6

          Thomas HILAIRE added a comment -

          QA: For me this ticket is OK because

          • I try with the same condition than you Antoine DUPRAT and my test succeed
          • I think that you've chosen a wrong timezone with the device as, by looking at your comment, the "StartTime" of its request is at 7AM (should be at 22PM for UTC+2 TZ) and the timezone is not the same than I received for my test

            People

            • Assignee:
              Thomas HILAIRE
              Reporter:
              Thomas HILAIRE
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: