Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.1.1
    • Fix Version/s: 3.2.0
    • Labels:
      None
    • Environment:

      CentOS release 6.7

    • Story Points:
      0
    • Rank:
      6965
    • Sprint:
      2016#01

      Description

      Code fixing it

      see branch thilaire/OP-232, we are testing it in production but unit tests still to be done

      Pre-conditions

      Fully capable OBM-stack splitted or in the same server.
      Have a configured healthcheck user for everydomain your OBM is controlling.

      Reproduction steps

      start spushnik probe and monitor it.

      Current behavior

      1. after an average time of 2 hours and 30 minutes. spushnik stops to work properly.
      2. It is also impossible to check the heap dump because there is not enough memory avaliable for the java runtime environment NOK

      Expected behavior

      1. we should not have to restart spushnik every 2 hours.OK

      Additional informations

        Activity

        Thomas HILAIRE made changes -
        Field Original Value New Value
        Project OBM [ 10022 ] Opush [ 10550 ]
        Key OBMFULL-6454 OP-232
        Affects Version/s 3.1.1 [ 12801 ]
        Affects Version/s 3.1.1 [ 12610 ]
        Component/s healthcheck [ 10593 ]
        Component/s spushnik [ 10890 ]
        Thomas HILAIRE made changes -
        Fix Version/s 3.1.2 [ 13200 ]
        Thomas HILAIRE made changes -
        Description h4. Pre-conditions
        Fully capable OBM-stack splitted or in the same server.
        Have a configured healthcheck user for everydomain your OBM is controlling.
        h4. Reproduction steps
        start spushnik probe and monitor it.


        h4. Current behavior
        # after an average time of 2 hours and 30 minutes. spushnik stops to work properly.
        # It is also impossible to check the heap dump because there is not enough memory avaliable for the java runtime environment {color:red}NOK{color}

        h4. Expected behavior
        # we should not have to restart spushnik every 2 hours.{color:green}OK{color}

        h4. Additional informations
        h4. Code fixing it
        see branch thilaire/OP-232, we are testing it in production but unit tests still to be done

        h4. Pre-conditions
        Fully capable OBM-stack splitted or in the same server.
        Have a configured healthcheck user for everydomain your OBM is controlling.
        h4. Reproduction steps
        start spushnik probe and monitor it.


        h4. Current behavior
        # after an average time of 2 hours and 30 minutes. spushnik stops to work properly.
        # It is also impossible to check the heap dump because there is not enough memory avaliable for the java runtime environment {color:red}NOK{color}

        h4. Expected behavior
        # we should not have to restart spushnik every 2 hours.{color:green}OK{color}

        h4. Additional informations
        Thomas HILAIRE added a comment -

        Impacts: verify that spushnik continue to work as expected for one request
        QA: should be tested with endurance tests (fix already validated in production)

        Jenkins Continuous Integration Server added a comment -

        SUCCESS: Integrated in opush-master-3.1 #36
        OP-232 Close streams used internally (thilaire: 931637abf2e63e972d32c2eaa739451b34d2fb1c)

        • spushnik-server/src/test/java/org/obm/push/spushnik/resources/ScenarioTest.java
        • spushnik-server/src/main/java/org/obm/push/spushnik/resources/Scenario.java
        • client/src/main/java/org/obm/sync/push/client/commands/TemplateDocument.java
          OP-232 Use 0 for the core pool size (thilaire: 90301c61fe0818b951e1c73037a08580e436f68b)
        • wbxml/src/main/java/org/obm/push/wbxml/WBXMLTools.java
        David Dolcimascolo made changes -
        Sprint 2016#01 [ 30 ]
        David Dolcimascolo made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        David Dolcimascolo made changes -
        Story Points 0
        Stephane COLSON added a comment -

        No need to test anything more that a simple healthcheck with opush. Already in LNG Prod

        Stephane COLSON made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Jenkins Continuous Integration Server added a comment -

        ABORTED: Integrated in opush-master #262
        OP-232 Close streams used internally (thilaire: 99b9c502e623b65bba87f6984445012b4fabb9d3)

        • spushnik-server/src/main/java/org/obm/push/spushnik/resources/Scenario.java
        • spushnik-server/src/test/java/org/obm/push/spushnik/resources/ScenarioTest.java
        • client/src/main/java/org/obm/sync/push/client/commands/TemplateDocument.java
          OP-232 Use 0 for the core pool size (thilaire: b74281a414d91c112bc9be4dea148b2afa360b34)
        • wbxml/src/main/java/org/obm/push/wbxml/WBXMLTools.java

          People

          • Assignee:
            David Dolcimascolo
            Reporter:
            Slim CADOUX
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Agile