Opush
  1. Opush
  2. OP-246

As a user, I see the user's "job title" in its display name

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Normal Normal
    • Resolution: Fixed
    • Affects Version/s: 3.2.0
    • Fix Version/s: 3.2.1
    • Labels:
      None
    • Rank:
      7050

      Description

      Reproduction steps have not been tested!

      Reproduction steps

      1. As admin with obm-ui, create a user usera with a job title
      2. As usera with obm-ui, send an email to admin
      3. As admin with opush, sync your device and list the mail from usera

      Current behavior

      1. NOK the job title is displayed

      Expected behavior

      1. OK only the name is displayed

      Additional informations

      ContactConverter line 74 should be "msc.setJobTitle(c.getTitle());"

        Activity

        Jenkins Continuous Integration Server added a comment -

        UNSTABLE: Integrated in opush-master #268
        OP-246 Map OBM title to AS job title (thilaire: 4189b9b19b6c7ba7044b39525afc5cf82d5e0889)

        • obm-backend/src/main/java/org/obm/push/contacts/ContactConverter.java
        • obm-backend/src/test/java/org/obm/push/contacts/ContactConverterTest.java
        Thomas HILAIRE added a comment -

        QA: reproduction steps
        Impacts: none

        Thomas HILAIRE added a comment -

        Closed: in production since several weeks


          People

          • Assignee:
            Thomas HILAIRE
            Reporter:
            Thomas HILAIRE
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: