Opush
  1. Opush
  2. OP-247

Too long time spent on SQL when Sync request have changes

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Normal Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.2.1
    • Labels:
      None
    • Rank:
      7067

      Description

      Pre-conditions

      • Having a huge opush_sync_state table (like a real production syncing for a while)
      • Have the BREAKDOWN logger activated

      Reproduction steps

      1. As usera with opush, sync

      Current behavior

      1. NOK too much time spent on SQL (like 90%)
        16:49:34.163 [INFO ] {BREAKDOWN} [t620059/cSync/r620231/lschurr@linagora.com] REQUEST:23997 (SQL:20245, EMAIL:2266 (CASSANDRA:38, OTHER:6228
        ), CASSANDRA:11, OTHER:1475)

      Expected behavior

      1. OK no much time spent

      How to solve that

      Some indexes are missing:

      CREATE INDEX ON opush_sync_state (last_sync);
      CREATE INDEX ON opush_sync_state (collection_id);
      CREATE INDEX ON opush_sync_state (device_id);
      

        Issue Links

          Activity

          Jenkins Continuous Integration Server added a comment -

          UNSTABLE: Integrated in opush-master #268
          OP-247 Add explanations in the upgrade doc (thilaire: b7b89dd6d6b90a5361660570e84269caac5782e7)

          • push-server/src/main/asciidoc/upgrades.adoc
          • push-server/src/main/asciidoc/opush.adoc
          Thomas HILAIRE added a comment -

          QA: reproduction steps
          Impacts: none

          Thomas HILAIRE added a comment -

          Closed: in production since several weeks


            People

            • Assignee:
              Thomas HILAIRE
              Reporter:
              Thomas HILAIRE
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: