Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Normal Normal
    • Resolution: Fixed
    • Affects Version/s: 3.0.0
    • Fix Version/s: 3.0.1
    • Labels:
    • Rank:
      6149
    • Sprint:
      Lyon Kanban

      Description

      Reproduction steps:

      • have an opush 3.0.0 and a cassandra
      • in cassandra, create a keyspace not named "opush" (so "mykeyspace" for example)
      • configure opush to use this keyspace (change it in /etc/opush/cassandra.ini)
      • restart opush
      • connect to CRaSH and run "schema install"

      Current behavior:
      Command output:

      % schema install 
      An error occurred when installing the schema: schema_version table does not exists
      

      It fails because CassandraService.errorIfNoTable always uses the keyspace "opush".

      Expected behavior:
      Command output:

      % schema install 
      Schema version 1 has been installed, please restart opush to get the service up
      

      After a restart opush must work correctly

        Activity

        Stephane COLSON added a comment -

        OK with opush version 3.0.1-rc3, tested on CentOS

        Thomas HILAIRE added a comment -

        Impacts & QA: only things explained in Reproduction steps and Expected behavior


          People

          • Assignee:
            Thomas HILAIRE
            Reporter:
            Thomas HILAIRE
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Agile