[OBMFULL-5975] obm should conflicts with opush < 3.0 Created: 21/May/14  Updated: 10/Jun/14  Resolved: 22/May/14

Status: Closed
Project: OBM
Component/s: packaging
Affects Version/s: None
Fix Version/s: 3.0.0

Type: Task Priority: Normal
Reporter: Matthieu EXT_BAECHLER Assignee: David Dolcimascolo
Resolution: Fixed Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Attachments: PNG File aptitudeOpush.png     PNG File Sélection_100.png    
Similar Issues: Show 10 results 
Rank: 6201

 Description   

When upgrading obm from 2.5 to 3.0, opush is left in version 2.5.
We should conflicts against opush < 3.0 in order to force the user to upgrade opush before upgrading obm.



 Comments   
Comment by Matthieu EXT_BAECHLER [ 22/May/14 ]

Either you upgraded opush to 3.0 before/during obm upgrade or it must be uninstalled

Comment by Jenkins Continuous Integration Server [ 22/May/14 ]

SUCCESS: Integrated in poll-next-30 487-58f0d13307c52c883f789cfd74d8075b6d763c18
OBMFULL-5975 obm-core now conflicts with opush < 3 (jkornobis: 58f0d13307c52c883f789cfd74d8075b6d763c18)

  • ui/rpm/SPECS/obm.spec
  • ui/debian/control
Comment by Stephane COLSON [ 23/May/14 ]

obm-jdk, obm-jetty and obm-jetty-common-libs are not removed after an upgrade on Debian Squeeze. Is it fair enough ?

Comment by Stephane COLSON [ 23/May/14 ]

See previous comment

Comment by Stephane COLSON [ 26/May/14 ]

Squeeze upgrade testing
With OBM 2.5.7 installed from scratch and upgraded with this apt.source on a squeeze

deb http://deb.obm.org/squeeze-backports squeeze main
deb http://deb.obm.org/30/contrib squeeze obm
deb http://deb.obm.org/30/next obm obm
root@obm15:~# aptitude upgrade
Résolution des dépendances...                 
Les NOUVEAUX paquets suivants vont être installés : 
  ca-certificates-java{a} libc-client2007e{a} libffi5{a} libjpeg8{a} liblcms2-2{a} libnspr4{a} libnss3{a} libpcsclite1{a} 
  libssl1.0.0{a} mlock{a} multiarch-support{a} openjdk-7-jre-headless{a} openjdk-7-jre-lib{a} php5-imap{a} php5-ldap{a} tzdata-java{a} 
Les paquets suivants seront ENLEVÉS : 
  jetty{u} jsvc{u} libcommons-daemon-java{u} libjetty-java{u} libservlet2.5-java{u} libslf4j-java{u} obm-jdk{u} obm-jetty{u} 
  obm-jetty-common-libs{u} opush{u} sun-java6-jdk{u} 
Les paquets suivants seront mis à jour : 
  ca-certificates fontconfig-config java-common libfontconfig1 libglib2.0-0 libobm-perl libobmsatellite-perl libpcre3 obm-ca obm-certs 
  obm-conf obm-core obm-cyrus obm-filter obm-full obm-ldap obm-locator obm-munin-master obm-munin-node obm-postfix obm-satellite 
  obm-services obm-solr obm-storage obm-sync obm-tomcat obm-tomcat-common-libs obm-ui openssl 
29 paquets mis à jour, 16 nouvellement installés, 11 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 107 Mo d'archives. Après dépaquetage, 21,6 Mo seront utilisés.

But after the upgrade, obm-jetty and opush are only marked for remove:

rc  obm-jetty                           2.5.7
rc  opush                               2.5.7

With another OBM install (2.5.0 upgraded to 2.5.7 version by version)

root@obm15:~# aptitude upgrade
Résolution des dépendances...                 
Les NOUVEAUX paquets suivants vont être installés : 
  ca-certificates-java{a} libffi5{a} libjpeg8{a} liblcms2-2{a} libnspr4{a} libnss3{a} libpcsclite1{a} libssl1.0.0{a} 
  multiarch-support{a} openjdk-7-jre-headless{a} openjdk-7-jre-lib{a} tzdata-java{a} 
Les paquets suivants seront mis à jour : 
  ca-certificates dpkg file fontconfig-config java-common libcurl3 libfontconfig1 libglib2.0-0 libmagic1 libmagickcore3 libmagickwand3 
  libpcre3 libxfont1 linux-base linux-headers-2.6.32-5-amd64 linux-headers-2.6.32-5-common linux-image-2.6.32-5-amd64 linux-libc-dev 
  obm-ca obm-munin-master obm-munin-node obm-tomcat obm-tomcat-common-libs openssh-client openssh-server openssl ssh tzdata 
  virtualbox-ose-guest-dkms virtualbox-ose-guest-utils virtualbox-ose-guest-x11 
Les paquets suivants sont RECOMMANDÉS mais ne seront pas installés :
  firmware-linux-free 
31 paquets mis à jour, 12 nouvellement installés, 0 à enlever et 17 non mis à jour.
Il est nécessaire de télécharger 91,7 Mo d'archives. Après dépaquetage, 115 Mo seront utilisés.

obm-core and opsuh is not removed. With aptitude interface mode, opush is suggested to be removed because in conflict with obm-opush < 2.3.3-1 (see aptitudeOpush.png)

Comment by David Dolcimascolo [ 06/Jun/14 ]

We'll document the use of aptitude to install and upgrade packages. So this ticket can be closed.

Comment by Stephane COLSON [ 10/Jun/14 ]

OK, I added a few links in http://obm.org/wiki/install-obm-debian-squeeze to make it clear that upgrading to OBM 3 must be done after upgrading Opush 3

Generated at Mon Sep 16 03:20:14 CEST 2019 using JIRA 6.1.1#6155-sha1:7188aeec9a6b57d61ea04c52f235f15f55c105e2.