OBM
  1. OBM
  2. OBMFULL-6473

T#16243 profile provisioning inverts rights

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Normal Normal
    • Resolution: Fixed
    • Affects Version/s: 3.1.6
    • Fix Version/s: 3.2.0
    • Component/s: provisioning-api
    • Labels:
    • Environment:

      CentO 6, Debian 7

    • Similar Issues:
      Show 10 results 
    • Rank:
      6943
    • Sprint:
      2016#01

      Description

      Test case 1

      Reproduction steps

      1. As admin0, define a new user profile having on calendar rights (profile_definition.png):
      • public read access disabled
      • public write access disabled
      1. Create a user with the new defined profile USING PROVISIONING (and not normal user creation in ui)

      As a side note, this can well be reproduced using a default profile and changing the default rights on it.

      Current behavior

      1. user's calendar has public read/write access disabled OK. In database, entityright_read = 1, entityright_write = 1 (entityright_table.png) NOK
      2. At event creation, all user agendas are writable by other users NOK

      Expected behavior

      1. user's calendar has public read/write access disabled. In database, entityright_read = 0, entityright_write = 0 OK
      2. At event creation, no event can be created by another user in the calendar of the user created with profile OK

      Test case 2

      Reproduction steps

      1. As admin0, define a new user profile having on calendar rights:
      • public read access disabled, checked
      • public write access disabled, checked
      1. Create a user with the new defined profile USING PROVISIONING (and not normal user creation in ui)

      As a side note, this can well be reproduced using a default profile and changing the default rights on it.

      Current behavior

      1. user's calendar has public read/write access disabled OK, not checked in the ui. NOK In database, entityright_read = 0, entityright_write = 0 NOK
      2. At event creation, no event can be created by another user in the calendar of the user created with profile NOK

      Expected behavior

      1. user's calendar has public read/write access disabled, checked in the ui. OK In database, entityright_read = 1, entityright_write = 1 OK
      2. At event creation, all user agendas are writable by other users OK

        Activity

        David Dolcimascolo added a comment -

        Simon ELBAZ

        je viens de reproduire
        si tu mets "Disabled" tu n'as pas a case dans ui, mais le droit est à 1 en base -> le droit devrait être à 0
        si tu mets "Disabled, Checked" tu as la case dans ui désactivée (mais décochée) et le droit est à 0 en base -> le droit devrait être à 1 (edited)
        c'est donc uniquement un problème de droits en base, comme je l'ai diagnostiqué
        toi tu indiques que dans ui les cases sont présentes et activées et les droits à 1 (edited)
        merci de vérifier

        David Dolcimascolo added a comment -

        To QA:

        • Limited impacts in obm-provisioning, as per the ticket description.
        • To test, have various profiles, with various default rights and create some users, veryfying each time that rights are correct when tou log in as the newly created user.

        Tested on CentOS7.

        Jenkins Continuous Integration Server added a comment -

        SUCCESS: Integrated in poll-master #222
        OBMFULL-6473 Fixed mapping of CheckboxState. (ddolcimascolo: e758d33ec5cd9d53a69593d6ddea0cb44daac686)

        • java/sync/provisioning-module/src/test/java/org/obm/provisioning/processing/impl/BatchProcessorImplUserTest.java
        • java/sync/obm-dao/src/test/java/org/obm/provisioning/dao/ProfileDaoJdbcImplTest.java
        • java/sync/obm-domain-objects/src/test/java/fr/aliacom/obm/common/profile/CheckBoxStateTest.java
        • java/sync/obm-domain-objects/src/main/java/fr/aliacom/obm/common/profile/CheckBoxState.java
        Stephane COLSON added a comment -

        This is not clear:
        I only have the following options "unchecked, checked, disabled or checked disabled" and the ticket talks about

        • public read access disabled, unchecked
        • public write access disabled, unchecked
        Stephane COLSON added a comment -

        What to reproduce is not clear: add screenshot of the current behavior (with a 3.1.6), what is wrong, what is expected with this fix.
        When I have public read/write access disabled, then a user with this profile have no checkbox in his public read/write access...seems correct to me with OBM 3.1.6.
        Is it only a problem in database ? If not, please add screenshots....and avoid copy/paste of FR #irc conversations, the problem should be understood quickly simply and with no ambiguity by reading the description

        Stephane COLSON added a comment - - edited

        Still don't understand and don't reproduce what I understand there.
        2 cases are described. Tested with version 3.1.6

        • For the first one, no other user can add any event to its calendar, no one have public R/W access and that's OK
        • For the second one, any one can add event in his calendar and this is normal because he gave publie R/W access and that's OK
        Stephane COLSON added a comment -

        OK, tested on Debian with OBM 3.2.0~0.alpha0+git20160428-1118-114e2c8
        with several type of profile and user creation with papi.
        Also, description has been modified and should now reflect reality (with OBM 3.1.6 and after the fix)


          People

          • Assignee:
            David Dolcimascolo
            Reporter:
            Simon ELBAZ
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Agile